SSL Certificate Expiry
Incident Report for OpenChannel
Postmortem

Our SSL certificate expired and we did not receive a notification.

We have switched to fully managed SSL certificates using AWS Certificate Manager. This means that our certificate lifecycle is now fully automated without the need for manual intervention when certificates expire.

Posted Jul 06, 2021 - 15:43 UTC

Resolved
We have switched to fully managed SSL certificates using AWS Certificate Manager. This means that our certificate lifecycle is now fully automated without the need for manual intervention when certificates expire.
Posted Aug 03, 2020 - 13:08 UTC
Investigating
Users are not able to list, search, view or install apps in the marketplace. In addition, partners are not able to create, save or submit apps to the marketplace. The API cannot be accessed due to a certificate error.
Posted Aug 03, 2020 - 12:44 UTC
This incident affected: Market API.