Customers closes to our EU datacenter are not able to login
Incident Report for OpenChannel
Resolved
The issue was due to a DNS change that we made during a change to expand global data centers.
Posted Oct 21, 2021 - 14:55 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2021 - 14:50 UTC
This incident affected: Dashboard.