Some users unable to log into my.openchannel.io
Incident Report for OpenChannel
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 09:17 UTC
Update
For some users they receive the error message "WRONG EMAIL OR PASSWORD, TRY AGAIN" even though their password is correct. We are investigating the issue.
Posted Jun 18, 2021 - 08:52 UTC
Investigating
We are currently investigating this issue.
Posted Jun 18, 2021 - 08:47 UTC
This incident affected: Dashboard.